奇点畅想

V1

2022/07/24阅读:75主题:红绯

陶博士月线反转6.0

陶博士月线反转6.0

月线反转缘由

很久没写文章了,这次介绍下陶博士的月线反转选股指标,郑重说明,此公式是来源于陶博士。先说下陶博士这月线反转公式比较合适于熊市中后期和牛市初期,总有那么一批好公司开始反转开启新的上升趋势旅程。 技术指标只是牛股启程的的一个指示,重要的还是基本面,重要的还是基本面,重要的还是基本面。

历史是最好的老师

历史是最好的老师,我们看看几张历史图,然后总结下月线反转需要那几个条件?

明星股之一:泰格医药 2017 年 10 月 10 日,出现月线反转,到 2018 年 07 月 18 日完成一轮上涨,区间涨幅 141%。2020 年 05 月 07 日,出现月线反转,到 2021 年 02 月 18 日结束,区间涨幅 131% 。

明星股之一:宁德时代 2019 年 11 月 27 日,出现月线反转,到 2021 年 12 月 06 日,完成一轮上涨,区间涨幅 650% 。

明星股之一:山西汾酒 2020 年 04 月 28 日,出现月线反转,到 2021 年 02 月 19 日,完成一轮上涨,区间涨幅 339%。

不在多举例子了,读者可以根据教程,设置后,自己摸索。上面上个例子是设置月线反转指标后可以看到买点的,金手指的地方开始上涨。

简单总结一下出现月线反转的条件:

  • 第一、出现信号时,经过了前期的平台调整,调整时间越长,成功率越高。
  • 第二、rps 必须强度够,大家看下下面的白,绿,黄,三条 rps 的强度都是红的,这里不清楚 rps 设置的可以看我上一篇文章。最好的 rps 形态是三条 rps 都又不红然后趋势上升,前后时间间隔不长同时红,可以看看宁德时代。

怎么设置月线反转?

该指标是使用通达信软件设置,代码来源于陶博士,这里郑重的感谢陶博士的无私奉献。

第一、 设置月线反转是依赖 rps 指标设置的,不清楚的同学,请看我这篇文章,或者看陶博士的 rps 设置教程。

第二、无脑复制下面的代码,郑重声明,此公式来源于陶博士,引用来写文章的博客,请声明出处。

技术指标设置

技术指标公式设置,在通达信软件界面,按 ctrl + F 打开公式管理窗口,选中技术指标公式下的其他类型,点击新建。

新建后,无脑复制下面公式,画线方法选择:主图叠加

注意:需要看自己 50 日 rps 引用的是那个数据源,本教程是引用数据源 1

公式如下: 陶博士月线反转 6.1 版本代码

Z:=EXTDATA_USER(1,0);{50天的}
RPS50:=Z/10;
FYX11:=IF(RPS50<=87,0,1);{RPS50大于87}
RPS5090:=IF(RPS50>=90,1,0);{RPS50大于90}
FYX120:=COUNT(RPS5090,60);
FYX121:=HHV(C,5)>=HHV(C,80) OR HHV(H,5)>=HHV(H,80);{创80日最高收盘价,或者创80日最高价}
FYX12:=FYX120>12 AND FYX121;{60天内RPS50大于90的天数多于12天,且创80日新高}
FYX13:=FYX120>18 AND FYX121 AND RPS50>=90;{60天内RPS50大于90的天数多于18天,且创80日新高,且当天RPS50大于90。在后面被FYX62、FYX72引用}
FYX1:=FYX11 OR FYX12;
FYX21:=LLV(L,50)>LLV(L,250) AND RPS50>=90;{50日内最低价大于250日内最低价,且RPS50大于90}
FYX22:=LLV(L,50)>LLV(L,200);{50日内最低价大于200日内最低价}
FYX23:=LLV(L,30)>LLV(L,200) AND HHV(H,5)>=HHV(H,200);{30日内最低价大于200日内最低价,且创200日新高}
FYX24:=LLV(L,30)>LLV(L,120) AND FYX12;{30日内最低价大于120日内最低价,且60天内RPS50大于90的天数多于12天}
FYX25:=LLV(L,20)>LLV(L,50);{20日内最低价大于50日内最低价}
FYX2:=(FYX21 OR FYX22 OR FYX23 OR FYX24) AND FYX25;{结构紧凑的重要条件}
NH80:=IF(H<HHV(H,80),0,1);
FYX31:=COUNT(NH80,10);{10天内曾创80日新高}
FYX32:=(C>=HHV(C,50) OR H>=HHV(H,50)) AND RPS50>=90;{当天创50日最高收盘价或50日最高价,且RPS50大于90}
FYX3:=FYX31 OR FYX32;
FYX4:=C>MA(C,20) AND C>MA(C,200) AND MA(C,120)/MA(C,200)>0.85;{当天收盘价必须站上20天线和200天线}
NN200:=IF(C>MA(C,200),1,0);{当天收盘价大于200天线}
AA200:=COUNT(NN200,45);
FYX51:=AA200>2 AND AA200<45;{45天内,收盘价站上200天线的天数大于2,小于45}
LNN200:=IF(L<MA(C,200),1,0);
LAA200:=COUNT(LNN200,45);
FYX52:=LAA200>0 AND AA200>2;{45天内,至少有一天的最低价低于200天线;且至少站上200天线3天以上}
FYX5:=FYX51 OR FYX52;
FYX61:=HHV(H,30)/LLV(L,150)<1.55;{30天内最高价与150日内最低价之比小于1.55}
FYX62:=HHV(H,30)/LLV(L,150)<1.75 AND FYX13;{30天内最高价与150日内最低价之比小于1.75,且满足FYX13}
FYX6:=FYX61 OR FYX62;
FYX71:=HHV(H,5)/HHV(H,120)>0.85;{5天内最高价距离120日内的最高价不到15%}
FYX72:=HHV(H,5)/HHV(H,120)>0.8 AND FYX13;{5天内最高价距离120日内的最高价不到20%,且满足FYX13}
FYX73:=C/HHV(H,10)>0.9;{当天收盘价距离10日内的最高价不到10%}
FYX7:=(FYX71 OR FYX72) AND FYX73;
YXFZ:=FYX1 AND FYX2 AND FYX3 AND FYX4 AND FYX5 AND FYX6 AND FYX7;
DRAWICON(BARSSINCEN(YXFZ,15)=0,LOW,11);{月线反转信号画图标34:黄色笑脸};

选股指标设置

选股指标设置只需要修改最后一句话就可以了,技术指标最后一句改为BARSSINCEN(YXFZ,15)=0;,不懂的无脑复制。

和技术指标的设置教程,差不多,技术指标公式设置,在通达信软件界面,按 ctrl + F 打开公式管理窗口,选中条件选股指标公式下的其他类型,点击新建。

选股指标公式代码:

Z:=EXTDATA_USER(1,0);{50天的}
RPS50:=Z/10;
FYX11:=IF(RPS50<=87,0,1);{RPS50大于87}
RPS5090:=IF(RPS50>=90,1,0);{RPS50大于90}
FYX120:=COUNT(RPS5090,60);
FYX121:=HHV(C,5)>=HHV(C,80) OR HHV(H,5)>=HHV(H,80);{创80日最高收盘价,或者创80日最高价}
FYX12:=FYX120>12 AND FYX121;{60天内RPS50大于90的天数多于12天,且创80日新高}
FYX13:=FYX120>18 AND FYX121 AND RPS50>=90;{60天内RPS50大于90的天数多于18天,且创80日新高,且当天RPS50大于90。在后面被FYX62、FYX72引用}
FYX1:=FYX11 OR FYX12;
FYX21:=LLV(L,50)>LLV(L,250) AND RPS50>=90;{50日内最低价大于250日内最低价,且RPS50大于90}
FYX22:=LLV(L,50)>LLV(L,200);{50日内最低价大于200日内最低价}
FYX23:=LLV(L,30)>LLV(L,200) AND HHV(H,5)>=HHV(H,200);{30日内最低价大于200日内最低价,且创200日新高}
FYX24:=LLV(L,30)>LLV(L,120) AND FYX12;{30日内最低价大于120日内最低价,且60天内RPS50大于90的天数多于12天}
FYX25:=LLV(L,20)>LLV(L,50);{20日内最低价大于50日内最低价}
FYX2:=(FYX21 OR FYX22 OR FYX23 OR FYX24) AND FYX25;{结构紧凑的重要条件}
NH80:=IF(H<HHV(H,80),0,1);
FYX31:=COUNT(NH80,10);{10天内曾创80日新高}
FYX32:=(C>=HHV(C,50) OR H>=HHV(H,50)) AND RPS50>=90;{当天创50日最高收盘价或50日最高价,且RPS50大于90}
FYX3:=FYX31 OR FYX32;
FYX4:=C>MA(C,20) AND C>MA(C,200) AND MA(C,120)/MA(C,200)>0.85;{当天收盘价必须站上20天线和200天线}
NN200:=IF(C>MA(C,200),1,0);{当天收盘价大于200天线}
AA200:=COUNT(NN200,45);
FYX51:=AA200>2 AND AA200<45;{45天内,收盘价站上200天线的天数大于2,小于45}
LNN200:=IF(L<MA(C,200),1,0);
LAA200:=COUNT(LNN200,45);
FYX52:=LAA200>0 AND AA200>2;{45天内,至少有一天的最低价低于200天线;且至少站上200天线3天以上}
FYX5:=FYX51 OR FYX52;
FYX61:=HHV(H,30)/LLV(L,150)<1.55;{30天内最高价与150日内最低价之比小于1.55}
FYX62:=HHV(H,30)/LLV(L,150)<1.75 AND FYX13;{30天内最高价与150日内最低价之比小于1.75,且满足FYX13}
FYX6:=FYX61 OR FYX62;
FYX71:=HHV(H,5)/HHV(H,120)>0.85;{5天内最高价距离120日内的最高价不到15%}
FYX72:=HHV(H,5)/HHV(H,120)>0.8 AND FYX13;{5天内最高价距离120日内的最高价不到20%,且满足FYX13}
FYX73:=C/HHV(H,10)>0.9;{当天收盘价距离10日内的最高价不到10%}
FYX7:=(FYX71 OR FYX72) AND FYX73;
YXFZ:=FYX1 AND FYX2 AND FYX3 AND FYX4 AND FYX5 AND FYX6 AND FYX7;
BARSSINCEN(YXFZ,15)=0;

如何使用?

技术指标公式

在股票代码日线公式界面上,右键,选中叠加其他指标的->技术指标->其他类型,上面新建的技术指标公式,既可以看到案例所示的金手指所指出现月线反转的地方。

选股指标

在通达信界面,按快捷键 ctrl + T ,调出条件选股条件窗口,选中月线反转,加入条件,即可选股。

下图是 2022-07-09 到 2022-07-16 时间段出现月线反转的股票,拿去不谢。

月线反转关键点

陶博士总结,我只是借花献佛。

第一、坚定不移地坚持股价相对强度RPS优先一切的最基本原则。原则上,RPS不翻红到达90以上的股票不买,对于基本面特别优秀的品种,RPS数值可以适当放宽到85左右。这个RPS,既可以是250日的RPS,也可以是120日的RPS,还可以是50日的RPS。并不是要求所有这三条RPS都翻红,也许其中一条翻红就可以考虑了。

第二、基本上都出现在熊市中后期和牛市初期。牛市中后期和熊市初期,很少有理想的月线反转信号。 因此,熊市第一轮重要的中期反弹及以后出现的月线反转信号,可以开始重视。 牢记一点,最优质的股票,从来只是在熊市中提前指数见底。牛市到来之后,才结束调整的股票大都是垃圾。

第三、股票的板块效应其实非常重要的。同一个板块的同类股票相继出现月线反转信号,则信号的可靠性就大幅提高了。特别是消费类股票集体出现月线反转信号,值得引起足够的重视。因为消费类股票代表着市场中最优质的一类股票,他们从来都是提前指数在熊市中开始反转出现N倍征程的。

扫扫下面二维码,关注公众号,内容更精彩 搜索公众号:奇点畅想

分类:

后端

标签:

后端

作者介绍

奇点畅想
V1