徐洲更

V1

2022/12/11阅读:50主题:全栈蓝

Ubuntu16.04安装R包magick出现的问题

太长不看版

  • magick的安装需要底层的imagemagick支持
  • Ubuntu16.04由于版本老旧,安装的旧版imagemagick无法使用
  • 使用spack自己安装新版,可以解决编译问题。

果子老师向我求助,让我帮忙安装一个R包, magick。这个R包,我在自己的CentOS系统的服务器上安装过,在我的Mac上装过,我觉得应该不是个大问题。

然而,从最后我所花的时间来看,这确实是个大问题,因为这是果子老师提出的问题,但凡是他提出的问题,他肯定是前期花了点时间的,也就是常规的路子都走过了,实在没法子才来找我出手。

这个信息的报错消息如下

magick.so: undefined symbol: _ZNK6Magick8GeometrycvNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEEv

我通过检索,发现有人通过设置~/.R/Makevars里的C++配置解决过

CXX11=/usr/bin/g++

但是,我测试过了这个方法,并不可行。不过,在这个思路下,我有两个猜测

  • R语言版本或许要最新版4.2.2,这是最简单的思路。很大一部分问题都可以通过升级R来解决。
  • GCC版本低,无法提供magick所要求的库。

对于第一个猜想,我编译了最新R4.2.2, 但是发现并不是原因。

对于第二个猜想,我得编译一个gcc,这个我在2018年的【无root权限下解决编译时的依赖问题】中介绍过,但是那个操作太复杂了,现如今可以考虑用spack(https://spack.io/)。

# 关于spack的安装和使用,不在此文介绍
spack install gcc
spack load gcc

但是,基于最新的GCC去编译R包依旧不行,甚至,基于最新的GCC编译的最新的R也不行。此时,我的心态有点暴躁,于是,我想着要不要就不在这台服务器上编译了,用另一台Ubuntu服务器编译好,复制过来不就好了吗?

但是,由于两台机子的Ubuntu版本不同,结果有依赖库的问题

错误: package or namespace load failed for ‘magick’ in dyn.load(file, DLLpath = DLLpath, ...):
 无法载入共享目标对象‘/home/xzg/R/x86_64-pc-linux-gnu-library/4.2/magick/libs/magick.so’::
  libMagick++-6.Q16.so.8: cannot open shared object file: No such file or directory

这个情况,有一种偷懒的方式,就是用ln 做了软连接

ln -s   /usr/lib/x86_64-linux-gnu/libMagick++-6.Q16.so /usr/lib/x86_64-linux-gnu/libMagick++-6.Q16.so.8  

然而,依旧报错(好消息不是之前的错误)

  /home/xzg/R/x86_64-pc-linux-gnu-library/4.2/magick/libs/magick.so: 
  undefined symbol: _ZN6Magick5Image10fontWeightEm

尽管失败了,但是我有了一个新的猜想, 那就是系统自带的Magick的版本低了。有没有一种可能,在R里,我安装旧版本的magick就可以避免这个问题呢?于是,我找到了它的历史存档 https://cran.r-project.org/src/contrib/Archive/magick/,从1.0测试到2.6 ,无一成功。

好吧,这条路也走不通,那我只能去编译一个最新的imagemagick

spack install imagemagick
spack load imagemagick

# 动态库,没有这行命令,编译过程最后一步还是失败
export LD_LIBRARY_PATH=/home/xzg/spack/opt/spack/linux-ubuntu18.04-skylake_avx512/gcc-7.5.0/imagemagick-7.0.8-7-663acxuiasjhkjxymveygisoduukdmpa/lib:$LD_LIBRARY_PATH

然后安装magick,终于这条路成功了!

终于,我可以断定,果子老师之所以安装不了magick是因为它的Ubuntu系统里没有安装最新的imagemagick底层库。之所以,他没法用下面的语句安装最新的imagemagick底层库,是因为它用的是16.04版本Ubuntu。

sudo apt-get update
sudo apt-get install -y libmagick++-dev

不过,问题还是没有顺利的解决,因为我们希望这个包是给所有人用的,而非自己用。

有两种方法,一种是让其他用户添加一个环境变量,LD_LIBRARY_PATH。

另一种方式,当你是root用户,你就可以在 /etc/ld.so.conf.d/里加上一个配置文件,比如说我的是,imagemagick-7.0.8-7-663.conf,里面是lib路径

/home/xzg/spack/opt/spack/linux-ubuntu18.04-skylake_avx512/gcc-7.5.0/imagemagick-7.0.8-7-663acxuiasjhkjxymveygisoduukdmpa/lib

然后调用ldconfig 让配置生效,就可以让我们自己编译的动态库变成系统级。

故事到这里基本就结束了,只有最后一个小插曲,那就是果子老师最终目标是安装spatialLIBD

BiocManager::install("spatialLIBD")

但是安装过程中,另一个R包textshaping出错,提示信息如下

--------------------------- [ANTICONF] --------------------------------
Configuration failed to find the harfbuzz freetype2 fribidi library. Try installing:
 * deb: libharfbuzz-dev libfribidi-dev (Debian, Ubuntu, etc)
 * rpm: harfbuzz-devel fribidi-devel (Fedora, EPEL)
 * csw: libharfbuzz_dev libfribidi_dev (Solaris)
 * brew: harfbuzz fribidi (OSX)
If harfbuzz freetype2 fribidi is already installed, check that 'pkg-config' is in your
PATH and PKG_CONFIG_PATH contains a harfbuzz freetype2 fribidi.pc file. If pkg-config
is unavailable you can set INCLUDE_DIR and LIB_DIR manually via:
R CMD INSTALL --configure-vars='INCLUDE_DIR=... LIB_DIR=...'
-------------------------- [ERROR MESSAGE] ---------------------------
<stdin>:1:10: fatal error: hb-ft.h: No such file or directory
compilation terminated.
--------------------------------------------------------------------
ERROR: configuration failed for package ‘textshaping’
* removing ‘/opt/R-4.2.1/lib/R/library/textshaping’

其实解决思路很简单,也就是用 apt install libharfbuzz-dev libfribidi-dev去安装这个依赖就好。然而,没有那么顺利

下列软件包有未满足的依赖关系:
 libfribidi-dev : 依赖: libfribidi0 (= 0.19.7-1) 但是 0.19.7-2 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系

不过,无所谓了,我直接用 spack自己装一份fribidi就好了。

参考资料

分类:

后端

标签:

后端

作者介绍

徐洲更
V1