1一乐

V1

2022/02/26阅读:26主题:默认主题

【关于开发工具的版本挑选问题】工具不是版本越新越好用,不要过于追求最新,好用性价比最高

1、工具:包括软件、插件、jar包等等,不是版本越新越好,理由如下:

(1)可能新版本收费了,emm,需要新版本的pojie,暂时大佬还在研究如何pojie呢~


(2)新版本刚迭代出来不稳定~找男人你都知道要找稳定靠谱的,何况是一个任你操作的工具,当然是稳定、省事、省心、高效、靠谱,多余的时间干其他事情不香吗

  • 东西稳定好用,让你情绪更加稳定,减少不必要麻烦,选工具就选稳定的,别人都用上了称好的,看视频学习,跟着视频的老师使用同款工具(版本一致),因为有经验的老师会先调好了一个稳定的工具,跟他保持同频,更好地模仿学习~

  • 使用新版工具的话,还得自己摸索怎么配置,出现问题怎么解决等等一系列.....,学习,何必自找麻烦,把精力花在重点上更重要。


(3)迭代出的新产品,多出来了很多功能,用不上,东西的价值是使用,没有使用,摆漂亮是没有意义的

  • 打个比方:请问你用得最熟悉的一款开发工具,你常用的功能是全部吗?不就那几个吗,还有,咱就说快捷键好了,常用的快捷键有很多,你用习惯的也就那几个:格式化代码、自动代码提示、换行等,用来用去,就是用那几个,多余的需要的时候,再手动敲一下得了~

(4)举例大家的选择,jdk-1.8; tomcat-9;sts-3等等

■ 再说说jar包,jar之间的关系也是要考虑版本的,举例:
  • 德鲁伊数据库连接池的版本是:druid-1.0.15.jar
  • 数据库驱动程序的版本是: mysql-connector-java-8.0.23.jar □ 结果显示:连接失败
  • 数据库驱动程序的版本是: mysql-connector-java-5.1.38.jar □ 结果显示:成功

■ 其中 sts工具(选择版本4后)的选择麻烦,可以看我的文章:

eclipse安装完对应的sts插件后按alt+/却不能提示属性值


稳定的工具,不好用了,或者市面更加流行哪个版本了(这个工具被使用多了,有很多分享的内容啦,遇到麻烦也容易解决),可以看情况选择了,一切都是为了省事省心,才更高效、更稳定输出

分类:

后端

标签:

后端

作者介绍

1一乐
V1