Y

Yimning

V1

2022/09/26阅读:14主题:默认主题

LINUX安装依赖库冲突,提示软件包有未满足的依赖关系、但是它将不会被安装、无法修正错误等

安装libx11

sudo apt-get install libx11-dev

报错如下:

解决:LINUX安装依赖库冲突

  1. 什么依赖冲突安装什么库
  2. 若错误中出现 >=的情形,直接安装这个库依赖。比如
 libglib2.0-dev : 依赖: libmount-dev (>= 2.28) 但是它将不会被安装
那么直接执行如下命令即可安装。
# sudo apt install libmount-dev

  1. 若出现了=,就安装等号后面的这个版本。如上图示
libx11-dev : 依赖:libx11-6 (=2:1.6.12-1)
那么执行命令安装
sudo apt-get install libx11-6=2:1.6.12-1
即可,见下图。
  1. 最后再回头安装目标软件

安装目标软件

分类:

后端

标签:

操作系统

作者介绍

Y
Yimning
V1